The issue has been resolved. The rollback deployed at 12:00 CEST has stabilized the system- database query performance and CPU usage on the database server have returned to normal levels
Posted May 20, 2026 - 12:39 CEST
Monitoring
We have now reverted the related changes and deployed the rollback to production.
We are currently monitoring the system, and performance is returning to normal.
Posted May 20, 2026 - 12:00 CEST
Identified
The issue has been identified, and we are currently working on deploying a fix.
The root cause was related to one of our recent changes, which caused a database query to time out and led to high CPU usage on the database server.
Posted May 20, 2026 - 11:20 CEST
Investigating
Some users may experience slower page loading or delayed responses in the application. We are investigating and working on a fix.