Degraded dashboard performance

Incident Report for Subrite Status

Resolved

The service is operating normally again.

Earlier today, some users may have experienced slower response times in parts of the admin portal. The issue has been resolved, and we have confirmed that the platform is functioning as expected.

Thank you for your patience.
Posted Jun 03, 2026 - 07:48 CEST

Identified

We have identified the cause of the slow performance affecting parts of the Admin Portal and are working on a resolution.
We expect the issue to be resolved within the next 30 minutes to 2 hours.
Posted Jun 03, 2026 - 07:17 CEST

Investigating

We’re currently seeing slower-than-usual load times in the admin dashboard. All other systems are operating normally. Our team is investigating and working on a fix. We’ll post an update as soon as the issue is resolved.
Posted Jun 03, 2026 - 06:37 CEST
This incident affected: Account page - Frontend.